Go Back   Oklahoma Ram Club > Dodge Ram > Technical/Repair


Reply
 
Thread Tools Display Modes
Old 01-18-2012, 10:24 PM   #1
(S.M.R) 101
Outdoorsman Member
 
(S.M.R) 101's Avatar
 
Join Date: Aug 2011
Location: Moore, OK / Corning, NY
Age: 33
Posts: 3,240
Default HVAC and or blower motor

So jumped in my truck this morning to take it for a spin since it's been in the garage from when I drove it last to the dealer and I had the heat on floor but seem'd to be really hot in my face area.. so I felt down by the pedals and there was not really any air blowing so I cranked it on high and same thing very little air.. it's all coming from the defrost vents on the dash....

So i'm guessing that little flap that directs the air has shit and bit it...

Any other things you guys can think of?
__________________


"Oilfield Outlaw"
(S.M.R) 101 is offline   Reply With Quote
Old 01-18-2012, 11:02 PM   #2
OklaHemi
SRT-10 Member
 
OklaHemi's Avatar
 
Join Date: Aug 2011
Location: Collinsville
Posts: 1,624
Default

Yes I think that is the blend door....
__________________
04 LowHemi
OklaHemi is offline   Reply With Quote
Old 01-18-2012, 11:09 PM   #3
(S.M.R) 101
Outdoorsman Member
 
(S.M.R) 101's Avatar
 
Join Date: Aug 2011
Location: Moore, OK / Corning, NY
Age: 33
Posts: 3,240
Default

Figured...... Any ideas what type of cash flow it cost to get that bitch replaced.
__________________


"Oilfield Outlaw"
(S.M.R) 101 is offline   Reply With Quote
Old 01-19-2012, 12:11 AM   #4
myoung84
Super Moderator
 
myoung84's Avatar
 
Join Date: Aug 2011
Location: Broken Arrow
Age: 34
Posts: 2,910
Default

Yep, sounds like the blend door. Not sure on how much to fix...
__________________

2014 Ram 1500 4x4 Outdoorsman
Retro Shop Custom FXR Projectors | Diablo inTune | Moe's 87mm TB | BT Oil Catch Can
Toyo A/T II Tires | Bilstein 5100 Front & Rear Shocks | AirLift 100 Air Bags
Bestop PowerBoards | RollBak Bed Cover | BedRug
myoung84 is offline   Reply With Quote
Old 01-19-2012, 01:57 AM   #5
(S.M.R) 101
Outdoorsman Member
 
(S.M.R) 101's Avatar
 
Join Date: Aug 2011
Location: Moore, OK / Corning, NY
Age: 33
Posts: 3,240
Default

Ohh I'm not even going to F with it... I'm going to have it fixed.
__________________


"Oilfield Outlaw"
(S.M.R) 101 is offline   Reply With Quote
Old 01-19-2012, 12:20 PM   #6
OU Hemi
Zachary
 
OU Hemi's Avatar
 
Join Date: Aug 2011
Location: Perry, OK
Age: 35
Posts: 152
Default

When I had my truck, I got quoted at several hundred I believe. They said they had to take the entire dash out.
__________________
OU Hemi is offline   Reply With Quote
Old 01-19-2012, 12:55 PM   #7
(S.M.R) 101
Outdoorsman Member
 
(S.M.R) 101's Avatar
 
Join Date: Aug 2011
Location: Moore, OK / Corning, NY
Age: 33
Posts: 3,240
Default

Nice.........

looking forward to that
__________________


"Oilfield Outlaw"
(S.M.R) 101 is offline   Reply With Quote
Old 01-19-2012, 01:06 PM   #8
myoung84
Super Moderator
 
myoung84's Avatar
 
Join Date: Aug 2011
Location: Broken Arrow
Age: 34
Posts: 2,910
Default

My blend door on my 04 broke the day after I bought it. The dealer took care of it so I don't know what it cost. They did have the truck for like 2 or 3 days though...
__________________

2014 Ram 1500 4x4 Outdoorsman
Retro Shop Custom FXR Projectors | Diablo inTune | Moe's 87mm TB | BT Oil Catch Can
Toyo A/T II Tires | Bilstein 5100 Front & Rear Shocks | AirLift 100 Air Bags
Bestop PowerBoards | RollBak Bed Cover | BedRug
myoung84 is offline   Reply With Quote
Old 01-19-2012, 02:04 PM   #9
(S.M.R) 101
Outdoorsman Member
 
(S.M.R) 101's Avatar
 
Join Date: Aug 2011
Location: Moore, OK / Corning, NY
Age: 33
Posts: 3,240
Default

Well I just talked with one of the tech's at the dealer and he says he does not think it's the blend door since every other setting is working.. the defrost works front vents everything but the floor..

So i'm taking it in next week to have them look at it.
__________________


"Oilfield Outlaw"
(S.M.R) 101 is offline   Reply With Quote
Old 01-19-2012, 08:46 PM   #10
rvarela
06ram
 
rvarela's Avatar
 
Join Date: Dec 2011
Location: Blanchard
Posts: 177
Default

that sucks, that happened to my truck too. must just be a crappy design or something.hope all goes well for you.
rvarela is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump